Niebelung

Optimum GPS doesn't atomize

Recommended Posts

Posted this in AGO today and wanted to give a shout out here as well... hoping for some assistance =)

 

-------------------

 

Tried using GPS today by hand, has a thick oily feel to it but it worked well in covering up very fine marring.

 

The only problem I had was that my GPS didn't atomize the way it did in Corey's (CEE DOG) video. It came out as a stream and splatted on the paint. This happened no matter which setting on the nozzle I turned it to =(

 

So it's a great AIO, just not sprayable for me unfortunately.

 

If it helps, the ambient temp I was working at is approx 92F and 60% humidity in the shade. The consistency of the product is more like a cream rather than a liquid like OCW.

Share this post


Link to post
Share on other sites

I would have to agree with the squeeze it like you mean it concept. I use the Spray compound and polish a lot and this was an issue I had till I adjusted myself into really pulling sharply on the trigger. If not, the product will just come out in a stream.

Share this post


Link to post
Share on other sites

As true as this is, you should also use common sense. I was trying to get the finest mist possible and really pulled back hard on the trigger when the nozzle setting was too closed. Snapped the trigger out of its housing, can't get to my compound anymore and it leaked a terrible mess. Like they say, common sense isn't common :bann[1]:

 

Trying to source a Tolco #320 sprayer head as I think Chris mentioned on another forum this is what they use.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now