Sign in to follow this  
BlackCamaro

Paint Correction Help Needed

Recommended Posts

Let me start off by saying that I'm a total noob to paint correction but have been detailing cars all my life.  My dad owns a funeral home so as early as I can remember I've been washing black cars in the hot Arkansas sun.  Wouldn't you know now that I'm grown I prefer owning black cars!  Thought I would give paint correction a shot on my black Camaro.  After doing some testing I settled on a 2 step of intensive polish on the orange optimum pad and then hyper polish on the orange opt pad.  The car is only 6 months old and the paint is great shape, as I have maintained it well.  Everything was going fairly well, removing 75% of the love scratches, until I got a little over half way and then I started introducing very tiny swirl marks.  I have tried many different things to remove them in the small area that I introduced them into with no luck.  I tried a wetter pad a drier pad, faster speed, slower speed, more hyper polish less hyper polish with no luck.  Finally I gave up.  I did notice that even though I was using the pad washer that the pad with hyper polish was pretty gummed up so I brought it in and cleaned it out really well with power clean.  I haven't had a chance to see if this helps but thought I would put it out here for the experts.  Could it simply be a dirty pad?  Or should I be using a dryer/wetter pad?  Just drives me crazy because things were going so well.  Could the pad be worn out????  

Thanks in advance for any advice you can provide.

James

Share this post


Link to post
Share on other sites

I'm sure more knowledgeable posters will weigh in, but 1 thought - the orange foam is a cutting pad, you might need a black polishing pad to take out the swirls. 

Share this post


Link to post
Share on other sites

I tried the black polishing pad with hyper polish and it left it very hazy.  I would be willing to try again.  Got a much better finish with orange/hyper polish combo.

Share this post


Link to post
Share on other sites

Was definatly a dirty pad.  Started back up with a clean pad and I was back in business.  So tonight I was more diligent to keep my pads clean, but had a different issue.  Hyper polish just stopped working and left the dull look from the intensive polish.  After I dried the pad out a bit it started back working again.  Not sure if the pad was too wet or just had too much hyper polish.  I'll keep plugging away at it and learning the products.

Share this post


Link to post
Share on other sites

Generally the foam pad should just be slightly damp before applying hyper polish/compound (ie prime in pad washer a few times then spin dry at speed 6 or highest speed).  For 5 and 6 inch pads generally one full pull of Hyper Polish is used (for 8 inch wool I use 1 and half sprays and 3 inch pads half spray).  It is important to thoroughly shake Hyper Polish (and other sprayable compounds) to ensure the abrasives in the liquid are well mixed to ensure consistent cut.  During Optimization training, Yvan recommended to add some stainless steel nuts to the bottle of Hyper Polish (and other sprayable compounds) which aids in mixing up the contents of the spray bottle when you shake it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this