AZSteve

Opti seal chalked my plastic trim?

Recommended Posts

I applied a coat of Opti Seal on my black plastic mirrors last evening and this morning they were chalky. I thought this was ok to be use don plastic and other surfaces?

I corrected it by scrubbing them down and then applying another product to them, but I was disappointed. I am not blaming the product as it could have very well be my misunderstanding and screw up. 

Share this post


Link to post
Share on other sites

I've never had Opti-Seal become chalky, not saying it's impossible, just never seen it.  My first instinct is to say Opti-Seal is reacting to something already on your mirrors.

Share this post


Link to post
Share on other sites

I never had any issues with opti seal being applied to anywhere...could you post some pics so we can see what we are dealing with?

 

Share this post


Link to post
Share on other sites

I notice you also have another thread where you say you "Opti Coated" your vehicle.  I'm not sure if you meant Gloss-Coat, since Opti-Coat is a pro-only product and Opti-Coat 2.0 (the one-time consumer version) has been off the market for many years.  Did you coat the mirrors before you applied the Opti-Seal?

Share this post


Link to post
Share on other sites

Yes, I applied Optimum Gloss Coat to my truck (not the trim) and then I top coated everything using Opti-Seal including the plastic trim and mirrors.  I didn't think to get pics as I corrected it afterward using Adams VRT. Thanks for the responses. 

Edit, the black mirrors, and trim on my truck are slightly textured. They looked great when I first applied the seal, but then a few minutes later they turned chalky and faded looking. I noticed when applying the Opti-Seal to the painted panels it would develop a very slight white haze that I would wipe off. It reminded me of applying a spray-on type ceramic. I might try to see if I can repeat this on the trim and take pics. 

Share this post


Link to post
Share on other sites

It sounds like you are using too much Opti-Seal (Disclaimer:  My Opti-Seal is the original version, from 1842 or whenever that was).  The reason I was asking if you coated the trim (with the Gloss-Coat) is that some of us have experienced "slivering" of trim when using trim coatings (not Gloss-Coat or other OPT coatings).  Apparently this can happen when you apply too much of those other coatings; it's like a "highspot", but usually takes much longer to appear.

Anyway, my experience with (and the point of) WOWA sealants is to NOT have to remove residue, so if you are having to wipe more than a few isolated "high spots" then (as Ron noted in his reply while I was typing this), I think you are applying too much.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now